$re = '/^(?!color=.*)^(?!color:.*)\#(\w*[a-zA-Z0-9]+\w*)/';
$str = '<font style="color:#FFFFFF">test</font>';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);