re = /^(?!color=.*)^(?!color:.*)\#(\w*[a-zA-Z0-9]+\w*)/
str = '<font style="color:#FFFFFF">test</font>'
# Print the match result
str.match(re) do |match|
puts match.to_s
end