using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<=[Nn]ame="")[^""]+";
string input = @"<Node Bla=""blabla"" Name=""this is my name"" .... />
<Node Name=""this is my name"" Bla=""blabla"" .... />";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}