re = /(?<=[Nn]ame=")[^"]+/
str = '<Node Bla="blabla" Name="this is my name" .... />
<Node Name="this is my name" Bla="blabla" .... />'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end