$re = '/^Numer właściciela:\s+(?<owner_id>.*?)(?=\s{20,}|$)/mu';
$str = 'Numer właściciela: NOWAKOWSKA 01-234 Warsaw
Numer właściciela: NOWAK_S6_2
Numer właściciela: KOWALSKA_S6_ 01-234 Warsaw
Numer właściciela: NOWACKI S6_ 01-234 Warsaw';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);