import re
regex = re.compile(r"^Numer właściciela:\s+(?<owner_id>.*?)(?=\s{20,}|$)", flags=re.MULTILINE | re.UNICODE)
test_str = ("Numer właściciela: NOWAKOWSKA 01-234 Warsaw\n"
"Numer właściciela: NOWAK_S6_2\n"
"Numer właściciela: KOWALSKA_S6_ 01-234 Warsaw\n"
"Numer właściciela: NOWACKI S6_ 01-234 Warsaw")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")