$re = '/^(?i)((?!reheat).)*$/m';
$str = 'maxReHeattemp
blah reHEAT
reheat
REHEAT
blah
blah blah
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);