re = /^(?i)((?!reheat).)*$/m
str = 'maxReHeattemp
blah reHEAT
reheat
REHEAT
blah
blah blah
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end