using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?!\((\'|"")*[^""\']+)\s*,\s*((?![^""\'(\)]*(\'|"")*\)))";
string input = @"sdfsf,sdfsdf(3,33),dfgdfgdg,sdfsdf(""hg,gh""),jhkjh(',k,k'),jhkjh('sd,'),jhkjh('sd'),asdad(','),asdasd("",sss"")";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}