re = /(?!\((\'|")*[^"\']+)\s*,\s*((?![^"\'(\)]*(\'|")*\)))/
str = 'sdfsf,sdfsdf(3,33),dfgdfgdg,sdfsdf("hg,gh"),jhkjh(\',k,k\'),jhkjh(\'sd,\'),jhkjh(\'sd\'),asdad(\',\'),asdasd(",sss")'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end