#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?!\([^\s*\,])\s*,\s*(?!.*('|")\))"
Local $sString = "sdfsf," & @CRLF & _
"sdfsdf," & @CRLF & _
"asdsd()," & @CRLF & _
"sdfsdf('3',33,"22")," & @CRLF & _
"dfgdfgdg," & @CRLF & _
"sdfsdf("hg,gh")," & @CRLF & _
"jhkjh(',k,k')," & @CRLF & _
"jhkjh('sd,')," & @CRLF & _
"jhkjh('sd')," & @CRLF & _
"asdad(',')," & @CRLF & _
"asdasd(",sss")," & @CRLF & _
"kjkj," & @CRLF & _
"hghjg(",jhgjh,h")," & @CRLF & _
"sdfsf:jhjh("")," & @CRLF & _
"sdfsf:jhjh("asd()asd,()")," & @CRLF & _
"hghjg(",(")," & @CRLF & _
"hghjg(',(WE2')," & @CRLF & _
"ASDASD," & @CRLF & _
"sdfsf:jhjh("asd(), asd)"),"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")