using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?!\([^\s*\,])\s*,\s*(?!.*('|"")\))";
string input = @"sdfsf,
sdfsdf,
asdsd(),
sdfsdf('3',33,""22""),
dfgdfgdg,
sdfsdf(""hg,gh""),
jhkjh(',k,k'),
jhkjh('sd,'),
jhkjh('sd'),
asdad(','),
asdasd("",sss""),
kjkj,
hghjg("",jhgjh,h""),
sdfsf:jhjh(""),
sdfsf:jhjh(""asd()asd,()""),
hghjg("",(""),
hghjg(',(WE2'),
ASDASD,
sdfsf:jhjh(""asd(), asd)""),";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}