package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^\d+\.?[a-zA-Z].*`)
var str = `1. TEST 1 : DataLogFile
11. TEST 2 : Inter Citro File
111. TEST 3 : Inter Citro File
111.TEST4 : Match this
111TEST5: Match this
111test6: Match this
test7: should not match
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}