re = /^\d+\.?[a-zA-Z].*/m
str = '1. TEST 1 : DataLogFile
11. TEST 2 : Inter Citro File
111. TEST 3 : Inter Citro File
111.TEST4 : Match this
111TEST5: Match this
111test6: Match this
test7: should not match
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end