using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?=.*[a-z])(?=.*[A-Z])(?=.*\d)(?=.*[$@!%*?&!""£$%^&*()_+{}:@~<>?|=[\];'#,.\/\\-])[A-Za-z\d$@!%*?&!""£$%^&*()_+{}:@~<>?|=[\];'#,.\/\\-]{8,}";
string input = @"aA3\abcd";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}