$re = '/(?=.*[a-z])(?=.*[A-Z])(?=.*\d)(?=.*[$@!%*?&!"£$%^&*()_+{}:@~<>?|=[\];\'#,.\/\\\\-])[A-Za-z\d$@!%*?&!"£$%^&*()_+{}:@~<>?|=[\];\'#,.\/\\\\-]{8,}/m';
$str = 'aA3\\abcd';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);