$re = '/\b(?!EFS)([A-Z]{1,4})\b/m';
$str = 'ABC $C so we have something it is the! EFS.. APPL so can we talk about a hold for $ABC';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);