re = /\b(?!EFS)([A-Z]{1,4})\b/m
str = 'ABC $C so we have something it is the! EFS.. APPL so can we talk about a hold for $ABC'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end