# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(?<!\w)(?:cat|dog(?:\ and\ cat)?)(?!\w)/animal/gm;t' <<< "I've been bad but I aspire to be a better person, and behave like my dog and cat :)"