import re
regex = re.compile(r"(?<!\w)(?:cat|dog(?:\ and\ cat)?)(?!\w)", flags=re.MULTILINE)
test_str = "I've been bad but I aspire to be a better person, and behave like my dog and cat :)"
subst = "animal"
result = regex.sub(subst, test_str)
if result:
print(result)