import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?sm)(^[^\\r\\n]*)[\\r\\n](?=.*^\\1)";
final String string = "In 1881, Paul Gauguin joked about how to extract Cézanne's mysterious methods, instructing Camille Pissarro to \"ply him with one of those mysterious homeopathic drugs and come straight to Paris\n\n"
+ "In 1881, Paul Gauguin joked about how to extract Cézanne's mysterious methods, instructing Camille Pissarro to \"ply him with one of those mysterious homeopathic drugs and come straight to Paris to share the information\". The painter and critic Maurice Denis shared a sense of bewilderment about Cézanne's revoluti\n\n"
+ "Cézanne's mysterious methods, instructing Camille Pissarro to \"ply him with one of those mysterious homeopathic drugs and come straight to Paris to share the information\".\n\n"
+ "In 1881, Paul Gauguin joked about how to extract Cézanne's mysterious methods, instructing Camille Pissarro to \"ply him with one of those mysterious homeopathic drugs and come straight to Paris to share the information\".\n\n"
+ "He overturned centuries of theories about how the eye works by depicting a world constantly in motion, affected by the passing of time and infused with the artist's own memories and emotions.\n\n"
+ "In 1881, Paul Gauguin joked about how to extract Cézanne's mysterious methods, instructing Camille Pissarro to \"ply him with one of those mysterious homeopathic drugs and come straight to Paris to share the information\".\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}