$re = '/(?sm)(^[^\r\n]*)[\r\n](?=.*^\1)/m';
$str = 'In 1881, Paul Gauguin joked about how to extract Cézanne\'s mysterious methods, instructing Camille Pissarro to "ply him with one of those mysterious homeopathic drugs and come straight to Paris
In 1881, Paul Gauguin joked about how to extract Cézanne\'s mysterious methods, instructing Camille Pissarro to "ply him with one of those mysterious homeopathic drugs and come straight to Paris to share the information". The painter and critic Maurice Denis shared a sense of bewilderment about Cézanne\'s revoluti
Cézanne\'s mysterious methods, instructing Camille Pissarro to "ply him with one of those mysterious homeopathic drugs and come straight to Paris to share the information".
In 1881, Paul Gauguin joked about how to extract Cézanne\'s mysterious methods, instructing Camille Pissarro to "ply him with one of those mysterious homeopathic drugs and come straight to Paris to share the information".
He overturned centuries of theories about how the eye works by depicting a world constantly in motion, affected by the passing of time and infused with the artist\'s own memories and emotions.
In 1881, Paul Gauguin joked about how to extract Cézanne\'s mysterious methods, instructing Camille Pissarro to "ply him with one of those mysterious homeopathic drugs and come straight to Paris to share the information".
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);