using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<=[一-龠]?)特許";
string input = @"東京特許許可局
東京特許許諾
北海道特許許可局
神奈川特許許可局
さいたま特許許可局";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}