$re = '/(?<=[一-龠]?)特許/m';
$str = '東京特許許可局
東京特許許諾
北海道特許許可局
神奈川特許許可局
さいたま特許許可局';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);