$re = '/(@\b[A-Za-z0-9]+\b)/m';
$str = '@kyrieirving’s
@jaytatum0';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);