package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(?:\s*\d{3}\s*\-?\s*\d{3}\s*)$`)
var str = `023056
023 056
023 056
023 056
023-056
023 - 056
023 - 056
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}