// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^(?:\s*\d{3}\s*\-?\s*\d{3}\s*)$").unwrap();
let string = "023056
023 056
023 056
023 056
023-056
023 - 056
023 - 056
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}