$re = '/http(s)?:\/\/[^\s]*\x{200b}[^\s]*/m';
$str = 'https://prime-link.net/kKiHr';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);