package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^[+-]?\d{1,3}.\d$`)
var str = `117,2`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}