$re = '/^[+-]?\d{1,3}.\d$/m';
$str = '117,2';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);