#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?:\d+\s+)(\w+)(?:\s+)(\w+)"
Local $sString = " Id Name State" & @CRLF & _
"----------------------------------------------------" & @CRLF & _
" 14 vm2 running" & @CRLF & _
" 19 vm7 running" & @CRLF & _
" 22 vm10 running" & @CRLF & _
" 27 vm11 running" & @CRLF & _
" 36 vm9 running" & @CRLF & _
" 38 vm12 running" & @CRLF & _
" 43 vm6 running" & @CRLF & _
" 46 vm1 running" & @CRLF & _
" 49 vm4 running" & @CRLF & _
" 63 vm5 running" & @CRLF & _
" 65 vm8 running" & @CRLF & _
" 67 vm3 running" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")