import re
regex = re.compile(r"(?:\d+\s+)(\w+)(?:\s+)(\w+)", flags=re.MULTILINE)
test_str = (" Id Name State\n"
"----------------------------------------------------\n"
" 14 vm2 running\n"
" 19 vm7 running\n"
" 22 vm10 running\n"
" 27 vm11 running\n"
" 36 vm9 running\n"
" 38 vm12 running\n"
" 43 vm6 running\n"
" 46 vm1 running\n"
" 49 vm4 running\n"
" 63 vm5 running\n"
" 65 vm8 running\n"
" 67 vm3 running\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")