import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "ugi=(?<ugi>[\\w]+)\\sip=(?<ip>[\\S]+)\\scmd=(?<cmd>[\\S]+)\\s(?<method>[\\S]+)[\\s]?:\\s(?<details>[\\S]+)";
final String string = "ugi=flink ip=172.18.214.55 cmd=source:172.18.214.55 alter_table: hive.net_seed.netdebugnetworkconnectionstatereadysnapshotcapturedevent newtbl=netdebugnetworkconnectionstatereadysnapshotcapturedevent\n"
+ "ugi=root ip=172.19.212.146 cmd=source:172.19.212.146 get_table : tbl=hive.nlx_dev.marrsqueryrewritecontextevent ";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}