import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^.{1,15}(?!ice\\W?)cream$";
final String string = "ice cream\n"
+ "foo bar icecream\n"
+ " cream\n"
+ "cream\n"
+ "scream\n"
+ "foo bar icecream\n"
+ "123456789012345cream\n"
+ "1234567890123456cream\n"
+ "12345678901ice cream\n"
+ "123456789012icecream\n"
+ "123456789012ice cream\n"
+ "1234567890123icecream\n"
+ "123456789012345cream\n"
+ "1234567890123456cream\n"
+ "I'm going to scream\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}