# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^.{1,15}(?!ice\W?)cream$"
test_str = ("ice cream\n"
"foo bar icecream\n"
" cream\n"
"cream\n"
"scream\n"
"foo bar icecream\n"
"123456789012345cream\n"
"1234567890123456cream\n"
"12345678901ice cream\n"
"123456789012icecream\n"
"123456789012ice cream\n"
"1234567890123icecream\n"
"123456789012345cream\n"
"1234567890123456cream\n"
"I'm going to scream\n")
matches = re.finditer(regex, test_str, re.MULTILINE | re.IGNORECASE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.