$re = '~(\[QUOTE[^][]*\])
(
(?:[^][]+|(?R))+
)
\[/QUOTE\]~x';
$str = '$string = \'Here is a quote [QUOTE=person]I am also quoting [QUOTE]this is a nested quote[/QUOTE][/QUOTE]\';';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);