re = /(\[QUOTE[^][]*\])
(
(?:[^][]+|(?R))+
)
\[\/QUOTE\]/x
str = '$string = \'Here is a quote [QUOTE=person]I am also quoting [QUOTE]this is a nested quote[/QUOTE][/QUOTE]\';'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end