using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?!.*\d{2,})[a-zA-Z0-9]*[a-zA-Z][a-zA-Z0-9]*$";
string input = @"love
i2p
111
1ab
ok
luana
okkffkkfkfkkfkkkfkfkfkkfkfkfkf
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}