re = /,(?![^,]+"\s*,)\s*/m
str = '1,2,3,4,5,"one, two", 6, 7, "three, four", 8, 9'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end