import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "#\\d+\\s[A-Z]\\d+(?:[,-]\\s?[A-Z]\\d+)*(?:;#\\d+\\s[A-Z]\\d+(?:[,-]\\s?[A-Z]\\d+)*)*";
final String string = "#2 A4-B7;#4 A1,B9 or #66 A1 or #88 C7 or #9999 E78-F39 or #567 E74;#678 Q7\n\n"
+ "#6 A1, B9, C7;#77 A89-Z78;#77 A89-Z78";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}