const regex = new RegExp('#\\d+\\s[A-Z]\\d+(?:[,-]\\s?[A-Z]\\d+)*(?:;#\\d+\\s[A-Z]\\d+(?:[,-]\\s?[A-Z]\\d+)*)*', 'gm')
const str = `#2 A4-B7;#4 A1,B9 or #66 A1 or #88 C7 or #9999 E78-F39 or #567 E74;#678 Q7
#6 A1, B9, C7;#77 A89-Z78;#77 A89-Z78`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}