# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"\n([\u0600-\u06ff\u0750-\u077f\ufb50-\ufbc1\ufbd3-\ufd3f\ufd50-\ufd8f\ufd92-\ufdc7\ufe70-\ufefc\uFDF0-\uFDFD-]+-)(.*)"
test_str = ("ألفاظُ الأذان جميعها مُثنّاة إلّا:\n"
"أ- التكبير.\n"
"ب- التهليل.\n"
"ج- كلاهما.\n"
"كثرةُ الفعل تُبطل الصَّلاة، ومقدارها:\n"
"أ- ثلاث حركاتٍ أو أفعال.\n"
"ب- خمس حركاتٍ أو أفعال.\n"
"ج- لا حدَّ لهُ وإنَّما مقدارهُ علىٰ العُرف.\n"
"سُجود السَّـهو:\n"
"أ- يجبر السُّنن ولا يجبر الفرائض.\n"
"ب- يجبر الفرائض ولا يجبر السُّنن.\n"
"ج- يجبر الفضائل ولا يجبر السُّنن.\n"
"د- يجبر السُّنن والفضَائِل والفرائِض.\n"
"الدُّعاء بالأعجميّة في الصلاة لَيْس مكروهًا:\n"
"أ- مُطلقاً.\n"
"ب- لغير القادر على الدُّعاء بالعربيَّة.\n"
"الكلامُ العمد لإصلاح الصَّلاة\n"
"أ- قليله غير مبطِل.\n"
"ب- قليله مبطل كثيره مبطل.\n"
"ج- قليله وكثيره غير مبطل.\n"
"ترك قراءة السُّورة بعد الفاتِحة يُسجد له سُجود:\n"
"أ- قبليّ.\n"
"ب- بعديّ.\n"
"يُشترط للوتر أن تُصلَّى ركعتا شفع قبله، وهذا شرط:\n"
"أ- وجوب.\n"
"ب- صحة.\n"
"ج- كمال.\n"
"د- وجوب وصحَّة معًا.\n"
"إقامةُ صَلاة الجَماعة بالوتر:\n"
"أ- سُنة.\n"
"ب- مندوب.\n"
"ج- مكروه.\n"
"الاستيطان من شروط …. الجمعة\n"
"أ- وُجوب.\n"
"ب- صحَّة.\n"
"يجوزُ الجَمع ولو لم تبلغ مسافة القَصر المُعتبرة شرعيًّا.\n"
"أ- صح.\n"
"ب- خطأ.\n"
"التغسيل والتكفين والحمل والدفن من:\n"
"أ- الواجبات تجاه الميّت.\n"
"ب- المندوبات تجاه الميّت.\n"
"ج- المُستحبات تجاه الميّت.\n"
"لا تجب الزكاة في مال غير البالغ العاقل.\n"
"أ- صح.\n"
"ب- خطأ.\n"
"تجب النية في صوم الفرض، ولا تجب في صوم التطوُّع.\n"
"أ- صح.\n"
"ب- خطأ.\n"
"ما يوجب القضاء والكفَّارة في الفرض، فإنه يُوجب …… في النَّفل.\n"
"أ- القضاء.\n"
"ب- القضاء والكفارة.\n"
"ج- لا يوجب شيئًا؛ لأنه نفل.\n"
"من توانى في قضاء أيَّام عليه من رمضان الماضي مفرّطًا حتى دخل عليه رمضان آخر فعَليه:\n"
"أ- القضاء فقط.\n"
"ب- القضاء والإطعام.\n"
"ج- الإطعام فقط.\n"
"طلب العلم أثناء الاعتكاف، كما ذكر الناظم -رحمه الله-:\n"
"أ- مستحب.\n"
"ب- مكروه.\n"
"ج- سُنَّة.\n"
"صيد الحيوان البري مُحرَّم داخل الحرم على:\n"
"أ- المُحْرِم.\n"
"ب- غير المُحْرِم.\n"
"ج- كليهما.\n"
"من شروط صحَّة الذبح التسمية:\n"
"أ- صحيح.\n"
"ب- خطأ.\n"
"الأضحية تُسنّ في حق الذكر دون الأنثى.\n"
"أ- صحيح.\n"
"ب- خطأ.\n"
"من نذر أن يُصلِّي في الجامع الأزهر فينبغي له أن يفي بهذا النذر في:\n"
"أ- الجامع الأزهر.\n"
"ب- أيّ مسجد.\n")
subst = ",\\1\\2"
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.MULTILINE)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.