import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "import(?:[\"'\\s]*([\\w*\\{\\}\\n, ]+)from\\s*)?[\"'\\s].*([@\\w/_-]+)[\"'\\s].*";
final String string = "import React from \"react\"\n"
+ "import { Field } from \"redux-form\"\n\n"
+ "<MenuItem value=\"^$\" primaryText=\"Não exibir importados\" />\n"
+ "<MenuItem value=\"\\\\w+\" primaryText=\"Exibir importados\" />\n";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}