package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`import(?:["'\s]*([\w*{}\n, ]+)from\s*)?["'\s].*([@\w/_-]+)["'\s].*`)
var str = `import React from "react"
import { Field } from "redux-form"
import {
PlaneBufferGeometry,
OctahedronGeometry,
TorusBufferGeometry
} from '../geometries/Geometries.js'
<MenuItem value="^$" primaryText="Não exibir importados" />
<MenuItem value="\\w+" primaryText="Exibir importados" />
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}