re = /import(?:["'\s]*([\w*{}\n, ]+)from\s*)?["'\s].*([@\w\/_-]+)["'\s].*/
str = 'import React from "react"
import { Field } from "redux-form"
import {
PlaneBufferGeometry,
OctahedronGeometry,
TorusBufferGeometry
} from \'../geometries/Geometries.js\'
<MenuItem value="^$" primaryText="Não exibir importados" />
<MenuItem value="\\\\w+" primaryText="Exibir importados" />
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end