using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"import(?:[""'\s]*([\w*{}\n\r\t, ]+)from\s*)?[""'\s].*([@\w/_-]+)[""'\s].*";
string input = @"import {
Component
} from '@angular2/core';
import defaultMember from ""module-name"";
import * as name from ""module-name "";
import { member } from "" module-name"";
import { member as alias } from ""module-name"";
import { member1 , member2 } from ""module-name"";
import { member1 , member2 as alias2 , member3 as alias3 } from ""module-name"";
import defaultMember, { member, member } from ""module-name"";
import defaultMember, * as name from ""module-name"";
import ""module-name"";
import {
PlaneBufferGeometry,
OctahedronGeometry,
TorusBufferGeometry
} from '../geometries/Geometries.js'
<MenuItem value=""^$"" primaryText=""Não exibir importados"" />
<MenuItem value=""\\w+"" primaryText=""Exibir importados"" />
";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}