# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"import(?:[\"'\s]*([\w*{}\n\r\t, ]+)from\s*)?[\"'\s].*([@\w/_-]+)[\"'\s].*"
test_str = ("import {\n"
" Component\n"
"} from '@angular2/core';\n"
"import defaultMember from \"module-name\";\n"
"import * as name from \"module-name \";\n"
"import { member } from \" module-name\";\n"
"import { member as alias } from \"module-name\";\n"
"import { member1 , member2 } from \"module-name\";\n"
"import { member1 , member2 as alias2 , member3 as alias3 } from \"module-name\";\n"
"import defaultMember, { member, member } from \"module-name\";\n"
"import defaultMember, * as name from \"module-name\";\n"
"import \"module-name\";\n"
"import {\n"
" PlaneBufferGeometry,\n"
" OctahedronGeometry,\n"
" TorusBufferGeometry\n"
"} from '../geometries/Geometries.js'\n\n"
"<MenuItem value=\"^$\" primaryText=\"Não exibir importados\" />\n"
"<MenuItem value=\"\\\\w+\" primaryText=\"Exibir importados\" />\n")
matches = re.finditer(regex, test_str)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.