package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)([0-9]+)-([0-9]+)`)
var str = `Street of hard-workers 2/12, 77-200, London`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}