$re = '/([0-9]+)-([0-9]+)/m';
$str = 'Street of hard-workers 2/12, 77-200, London';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);