using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"26";
string input = @"test_farm_26
26_test_farm
a26
";
RegexOptions options = RegexOptions.IgnoreCase | RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}